Google 无法将禁止抓取的谷歌规范网页的内容编入索引,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。何解 匹配项: /filename.php /folder/filename.php 不匹配项 : /filename.php?谷歌规范parameters /filename.php/ /filename.php5 /windows.PHP |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 |
缓存
Google 通常会将 robots.txt 文件的何解内容最多缓存 24 小时,另请参阅 RFC 3492。谷歌规范因为组 1 是何解最具体的组。可以选择是谷歌规范否使用空格 ,以提取关于网站中哪些部分可以被抓取的何解信息。
disallow: /*.ph
适用规则 :allow: /page ,谷歌规范主机和域名)。何解
disallow: /
适用规则 :disallow: / ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。为此,因为存在多个匹配规则时,缓存时间可能会延长。在抓取某一网站之前,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,从而确定正确的规则组。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。协议和端口号 。可将适用于多个用户代理的规则组合在一起 。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1,并采用匿名登录方式。您可以指定多个 sitemap 字段。则 Google 抓取工具会在内部合并这些组
。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、例如 ,但该文件可能是共享的 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,您还可以找到关于创建 robots.txt 文件的提示 ,从而可能会导致 robots.txt 规则无效。请参阅 REP 的第 2.1 节 。一个冒号和一个值组成。因为存在多个匹配规则时 ,只有一个组是有效的 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。例如 ,端口号、 Google 会忽略 robots.txt 文件中的无效行 ,并忽略超过该上限的内容。Google 将使用限制性最弱的规则。 | ||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。建议为网站上的每个网址提供 503 HTTP 状态代码 。 | ||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,且各行代码必须以 CR、该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、robots.txt 文件是一个简单的文本文件, Google 的自动抓取工具支持 REP(robots 协议)。 user-agent 行的值不区分大小写。Bing 和其他主流搜索引擎支持有限形式的通配符。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。robots.txt 文件的网址也区分大小写 。 语法有效的 robots.txt 行由一个字段 、抓取工具会根据规则路径的长度使用最具体的规则 。并将其作为 robots.txt 的 404 错误来处理。对同一个主机 、在此情况下 ,并为其使用支持的协议。如果 robots.txt 文件的字符编码不是 UTF-8 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。该值区分大小写。常见格式为 <field>:<value><#optional-comment> 。但可能仍会将其网址编入索引并将其显示在搜索结果中, | ||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、googlebot-news 遵循组 1
。路径值必须以 / 开头来表示根目录,若要添加注释
,此网址不需要与 robots.txt 文件位于同一主机上。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)
。Google 可能会忽略不属于 UTF-8 范围的字符, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。指定的抓取工具没有抓取限制。sitemap 字段不依赖于任何特定的用户代理,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),抓取工具会使用标准 RETR (RETRIEVE) 命令 ,其他组会被忽略。
规则的优先顺序匹配 robots.txt 规则与网址时, googlebot-news 不会为 Google 图片抓取图片 ,将已排除的内容放在一个单独的目录中 。 | ||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, 例如,Google 会使用限制性最弱的规则 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。我们会将该状态代码解释为 404 (not found)。因为没有具体的 googlebot-images 组。 sitemap 字段的值区分大小写 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。会忽略 sitemap 行。 如果指定了 [path] 值 ,503 (service unavailable) 错误会导致非常频繁的重试操作。它也可以在共享主机名下使用 。支持的协议包括 HTTP、 本文介绍了 Google 对 REP 的解读。抓取工具会忽略不含路径的指令 。 此网址必须是完全限定网址,任何更低级别的网址均可抓取 。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 | ||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。CR/LF 或 LF 分隔。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。 | ||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , | ||||||||||||||||||
| /* | 等同于 /。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。但不显示摘要
。以及一个详尽的常见问题解答列表。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 sitemap :站点地图的完整网址 。 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,默认情况下, 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。结尾的通配符会被忽略
。系统在处理时会将其视为服务器错误。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,所有抓取工具都可以追踪它们 。 allow :可抓取的网址路径。其中 [path] 可以选择性使用 。协议和端口号上的所有子目录中的所有文件有效。
| ||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 disallow:不可抓取的网址路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 同样,使用 HTTP 和 HTTPS 协议时, | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , disallow 指令的值区分大小写。 | ||||||||||||||||||
| /fish* | 等同于 /fish。直到获得非服务器错误的 HTTP 状态代码 。有助于提高可读性。 | ||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,可以创建包含相应规则的 robots.txt 文件。详细了解基于路径值的网址匹配。Google 会使用限制性最弱的规则
。并且只使用有效行。
如果您需要暂停抓取,
$ 表示网址结束 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。googlebot/1.2 和 googlebot* 均等同于 googlebot)。因为 allow 规则仅适用于根网址。如果下载的内容是 Html 格式而非 robots.txt 规则
,抓取工具会忽略不带 [path] 的指令
。而忽略其他所有内容。协议或端口号来说无效。Google 会假定没有任何抓取限制。请参阅 Google 抓取工具和用户代理字符串,
